qTranslate plug-in fiks

apr 21, 2015
admin

Vi har oplevet, at mange har problemer med qTranslate plug-in, så snart WordPress laver en opdatering. Plug-in’et de-aktiveres automatisk. Det kan i nogle tilfælde føre til fejl, hvis WordPress opgradere sig selv. Problemet opstår i #qtranslate/qtranslate.php:90 – Her defineres nuværende wordpress version. Et hurtigt fiks er at ændre det til nuværende wordpress version, eksempeltvis:

define(‘QT_SUPPORTED_WP_VERSION’, ‘4.1.1’;  –>  define(‘QT_SUPPORTED_WP_VERSION’, ‘4.1.2’);

Men så opstår samme problem igen så snart WordPress skal opdateres igen. Ændre derimod linjen til følgende:

define(‘QT_SUPPORTED_WP_VERSION’, $GLOBALS[‘wp_version’]);

Det sikrer, at qTranslate ikke vil de-aktivere sig selv automatisk, og at brugerne af websiden ikke bliver irriteret over fejlen.